34,948 Pages

This Forum has been archived

Visit Discussions
Forums - Anakin Skywalker page broken?
This page is waiting to be archived by an administrator. Please do not edit the contents of this page.

Anakin Skywalker

Basically- is anyone else having problems like this (below) when they try to view the Anakin Skywalker page? I have no idea what's wrong with it- I've looked at the page's code, I've looked at the code for the transcluded pages, and I can't see the problem.


I don't know about the Wikia skin, but the Monobook appearance usually comes about due to unclosed tags, etc. Any help/feeedback as to whether you're having a problem would be greatly appreciated. Thanks, NightblazeSaber 05:03, January 9, 2012 (UTC)

  • When this happens, Let the page load. If that does not work, Edit and copy and paste the page onto something else. --Czech 05:09, January 9, 2012 (UTC)
    Yeah, I'm getting a glitch too only on this page. Here is the screenshot. :/  Zaersk  Talk  Contribs  (MOC) (Blog) 05:46, January 9, 2012 (UTC)
    What I find is that aftyer a page has reached a certain length it does that. It happened to my talkpage, Cligra's, and NBP's. So I think it is something with Wikia and not so much browsers. klagoerRollinglaughingsmileyname that user 13:35, January 9, 2012 (UTC)
  • I'll have a look. I removed the big background section to see what difference length made but it made none. I've tried clearing cache and nothing has changed there. (Mine looks like Zearsk's image, but in Firefox) - CJC 17:35, January 9, 2012 (UTC)
  • I got a similar image. I find this usually happens when you have to many complicatedly nested tables, but I can't find anything wrong here. - nxt
  • @CJC: I don't think it can have anything to do with length- I checked the Obi-Wan page which is longer, and it seems fine to me. @NXT: I'm thinking tables too, because there at the top of the semantic table (which is invisible to all of you unless you've got it in your personall CSS to show), after the part where it says "Facts about Anakin Skywalker", there is "<tr><td class="smwpropname">Years</td><td class="smwprops">1999, 2000, 2002, 2005, 2007 - 2012</td></tr></table></div>", which to me seems to indicate something's wrong with a table, which would indicate the infobox, but why would it break only on this page? NightblazeSaber 22:37, January 9, 2012 (UTC)
    • I see that as well. I'm getting a problem as well, but different to both of the images above. Strange...Jag 22:53, January 9, 2012 (UTC)
  • Glitch started with this edit, if that narrows things down. ajr 23:17, January 9, 2012 (UTC)
    • No! Couldn't it have started with a - you know, shorter edit?? :D Anyway, from analyzing the source code, I have noticed a discrepancy between the number of <td's and the number of </td's, and the same with tr. Jag 00:13, January 10, 2012 (UTC)
  • I get the problem, too. Unsigned comment by Agent Charge (talk • contribs).
  • I had a problem with a user testing on the page, and told him to take his test edits to either the Sandbox or his Userspace. He copied the whole Anakin page over and it looked fine, so it must be with the page and not the text itself. If that helps at all. --Berrybrick (Talk) 00:16, January 10, 2012 (UTC)
    • I wouldn't say that was a problem. (i.e., I didn't get a warning when I removed half the page to test it), but either way, tests will have to be done on the page to fix it... - CJC 17:21, January 10, 2012 (UTC)
  • @Ajr/Jag- yeah, sorry about doing that in one go :P But the thing is, the problem on the page didn't start showing up until a few weeks ago- I know now the problem shows up between those edits, but the page was fine before :S @Berrybrick- I just copied everything to Anakin Skywalker/test, and it had the same error. However, that gave me an idea, I'm removing parts of the page to narrow down the error NightblazeSaber 01:09, January 10, 2012 (UTC)
  • Ok, so it seems that

|Variations =
Padawan {{C|Cape}}<br />
Padawan {{C|No cape}}<br />
The Clone Wars {{C|Version 1}}<br />
Jedi {{C|Light-up lightsaber}}<br />
Burnt {{C|Version 1}}<br />
Dark Side {{C|Episode 3}}<br />
See also: [[Darth Vader]]

will cause an error, but if you remove any of them, there won't be an error anymore :S NightblazeSaber 01:26, January 10, 2012 (UTC)

  • I think I've fixed the missing td, (hopefully I haven't ruined every infobox on the wiki by changing that). However, it didn't help to fix the page. 01:57, January 10, 2012 (UTC)
    • I don't think you have. It was on every page (well, at least out of the 2 I tried :D) but the Anakin Skywalker page also had an extra </td> Jag 01:59, January 10, 2012 (UTC)
      • Don't suppose you can tell me where? took me ages to find the first one :) NightblazeSaber 02:02, January 10, 2012 (UTC)

For me, there is still brick background where trhe text is. Legosuperheroesfan 12:37, January 10, 2012 (UTC)

  • I don't even have a brick bagkround :P Mine is just blue (It is on all pages actually :S ) - CJC 17:21, January 10, 2012 (UTC)
    <dont look at me...> - nxt
  • Just a heads up, this isn't a page size issue. I recently compared the sizes of the Anakin Skywalker and Obi-Wan Kenobi pages, and it seems like the Obi-Wan Kenobi page is larger than the Anakin Skywalker page by roughly 1,800 bytes! And the Obi-Wan page doesn't even have the problem! So this is definitely not a page size issue. Screenshot 1 | Screenshot 2.  Zaersk  Talk  Contribs  (MOC) (Blog) 18:47, January 10, 2012 (UTC)
  • request for closure: Rappy 4187 fixed the problem for us. issue.  Zaersk  Talk  Contribs  (MOC) (Blog) 19:03, January 10, 2012 (UTC)
Community content is available under CC-BY-SA unless otherwise noted.